Zelon's Blog

구글의 javascript library 사용하여 플래시 플레이어 버젼 확인하기

2009-09-23 22:55:09

 다음과 같은 코드를 통해서 현재 웹 브라우져의 플래시 플레이어 버젼을 확인할 수 있다. 특정 버젼 이상(유튜브의 경우 8 이상이어야한다)이 필요할 경우 체크할 때 사용하면 된다.

<script src="http://www.google.com/jsapi" type="text/javascript"></script>
<script type="text/javascript">
google.load("swfobject", "2.1");
google.setOnLoadCallback(onLoad);
function onLoad()
{
    var flashVersion = swfobject.getFlashPlayerVersion();
  
    alert("Flash version : " + flashVersion.major + "." + flashVersion.minor);
}
</script>

참고로 IE6 의 경우 기본적으로 버젼 6 이 깔려있다.